Modemsite's Forum56 - The Modem Board
Main | profile | register | search | help | Ad-free Login
Forums | USR | Can't get V.90 connection thou the line is capable    Watch  
Author Topic
Tl Posts:

Posted - 2/13/2001 7:23:02 PM  Show Profile  Email Poster  Edit Message
This is a tough question. I welcome to the bravest one who dares to answer it ! :)

I bought recently a 3Com U.S. Robotics 56K Message Modem.
At the end are pasted the AT relevant stuff.

The problem is I can't get any V.90 connection. I only get V.34 or V.34+.

The line is V.90 capable because I get 40-44 K with another modem ( a cheap HSP winmodem ) and
the substraction from the ATY11 between the value reported at 3750 and 3300 hz is 6, wich is very good.

The firmware seems to be the last according to the Internet Update Wizard.
I've tried with both the 3Com version and the U.S.R. version, with the folowing resulting links :

One link download a 0 bytes upgrade.exe and the other returs a page telling I have the latest code.
Although it seems to me that the flash date 3/2/99 is very old.

I've tried with everyting unplugged, and the modem directly connected to the incoming telco wires.

One thing that seems unusual to me is the hanshake. I believe this is the key of the problem.
After 6 or 7 sec. from the first high pitched sound, the modem speaker remain quiet for about 5 seconds
( total silence ) and after that, the hanshake continue.

According to what I've read this problem may indicate an bad compatibility between the modem and the ISP hardware.

So I've tried with four different ISP ( I don't know exactly what hardware are they running but seems
very unlikely that all of them are incompatible ) and happens exactly the same.

I suspected the modem was somehow broken or defective.
So I have sent back the modem to the site where I bought it and asked for a replacement.
When I get the replacement, everything is the same.

Please, I've tried everything and haven't any success. I need some light.

As you surely have guessed I'm no natively english speaker. I'm in Argentina.

Regarding the connection of the cheap HSP modem, it usually connect at 40000
or 44000 wich of course doesn't tell us if it's V.90 or K56Flex.

But the HSP sometimes connect at :


Which of course it's only a V.90 possible value.

So i'm pretty sure that the line is V.90 and so the ISP.

I believe the key of the problem is the 5 sec. of silence at the start of the hanshake.

But this happens no matter what ISP I call. ( I've tried 4 of them )

If I disabe x2 through S32 register ( S32=34) there's no 5 sec pause in the
hanshake ( the connection is a lot faster ) but at V.34 o V.34+ speeds only.

I can't get any response from 3COM / USR support !

Thanks in advance.

This are the relevant AT responses

U.S. Robotics 56K Message Rev. 14.10.1

Configuration Profile...

Product type Asia External
Product ID: 45566801
Options V32bis,V.80,V.34+,x2,V.90
Fax Options Class 1/Class 2.0
Line Options Caller ID
Voice Options Speakerphone, TAD
Clock Freq 92.0Mhz
EPROM 256k
RAM 32k

FLASH date 3/2/99
FLASH rev 14.10.1

DSP date 3/2/99
DSP rev 14.10.1

PTT Approval rev 1.0.0


Freq Level (dB)

150 18
300 16
450 15
600 15
750 15
900 15
1050 15
1200 15
1350 15
1500 15
1650 15
1800 15
1950 15
2100 16
2250 16
2400 16
2550 16
2700 16
2850 16
3000 16
3150 16
3300 16
3450 17
3600 19
3750 22

And modemlog.txt

02-09-2001 22:33:01.10 - U.S. Robotics 56K Message in use.
02-09-2001 22:33:01.11 - Modem type: U.S. Robotics 56K Message
02-09-2001 22:33:01.11 - Modem inf path: 3COMCO~1.INF
02-09-2001 22:33:01.11 - Modem inf section: Modem1
02-09-2001 22:33:01.36 - 115200,N,8,1
02-09-2001 22:33:01.41 - 115200,N,8,1
02-09-2001 22:33:01.44 - Initializing modem.
02-09-2001 22:33:01.44 - Send: AT<cr>
02-09-2001 22:33:01.44 - Recv: AT<cr>
02-09-2001 22:33:01.56 - Recv: <cr><lf>OK<cr><lf>
02-09-2001 22:33:01.56 - Interpreted response: Ok
02-09-2001 22:33:01.56 - Send: AT&F&B1&A3E0Q0V1&C1&D2&P1S0=0<cr>
02-09-2001 22:33:01.56 - Recv: AT&F&B1&A3E0Q0V1&C1&D2&P1S0=0<cr>
02-09-2001 22:33:01.70 - Recv: <cr><lf>OK<cr><lf>
02-09-2001 22:33:01.70 - Interpreted response: Ok
02-09-2001 22:33:01.70 - Send: ATS7=60S19=0L0M1&M4&K1&H1&R2&I0B0X4<cr>
02-09-2001 22:33:01.82 - Recv: <cr><lf>OK<cr><lf>
02-09-2001 22:33:01.82 - Interpreted response: Ok
02-09-2001 22:33:01.82 - Dialing.
02-09-2001 22:33:01.82 - Send: ATDT;<cr>
02-09-2001 22:33:03.38 - Recv: <cr><lf>OK<cr><lf>
02-09-2001 22:33:03.38 - Interpreted response: Ok
02-09-2001 22:33:03.38 - Dialing.
02-09-2001 22:33:03.38 - Send: ATDT###########<cr>
02-09-2001 22:33:32.87 - Recv: <cr><lf>CONNECT 33600/ARQ/V34/LAPM/V42BIS<cr><lf>
02-09-2001 22:33:32.87 - Interpreted response: Connect
02-09-2001 22:33:32.87 - Connection established at 33600bps.
02-09-2001 22:33:32.87 - Error-control on.
02-09-2001 22:33:32.87 - Data compression on.
02-09-2001 22:34:09.14 - 115200,N,8,1
02-09-2001 22:34:19.13 - Hanging up the modem.
02-09-2001 22:34:19.13 - Hardware hangup by lowering DTR.
02-09-2001 22:34:19.26 - Recv: <cr><lf>NO CARRIER<cr><lf>
02-09-2001 22:34:19.26 - Interpreted response: No Carrier
02-09-2001 22:34:19.26 - Send: ATH<cr>
02-09-2001 22:34:19.38 - Recv: <cr><lf>OK<cr><lf>
02-09-2001 22:34:19.38 - Interpreted response: Ok
02-09-2001 22:34:19.45 - Session Statistics:
02-09-2001 22:34:19.45 - Reads : 651 bytes
02-09-2001 22:34:19.45 - Writes: 672 bytes
02-09-2001 22:34:19.45 - U.S. Robotics 56K Message closed.


ATZ and AT&F1 With another ISP


U.S. Robotics 56K Message Link Diagnostics...

Chars sent 3 Chars Received 127
Chars lost 0
Octets sent 3 Octets Received 111
Blocks sent 3 Blocks Received 4
Blocks resent 0

Retrains Requested 0 Retrains Granted 1
Line Reversals 0 Blers 0
Link Timeouts 0 Link Naks 0

Data Compression V42BIS 2048/32
Equalization Long
Fallback Enabled
Protocol LAPM
Speed 33600/33600
Current Call 00:00:22


U.S. Robotics 56K Message Link Diagnostics...

Modulation V.34+
Carrier Freq (Hz) 1959/1959
Symbol Rate 3429/3429
Trellis Code 64S-4D/64S-4D
Nonlinear Encoding ON/ON
Precoding OFF/ON
Shaping ON/ON
Preemphasis (-dB) 0/6
Recv/Xmit Level (-dBm) 21/17
Near Echo Loss (dB) 32
Far Echo Loss (dB) 51
Carrier Offset (Hz) 42
Round Trip Delay (msec) 4
Timing Offset (ppm) 656
SNR (dB) 38
Speed Shifts Up/Down 0/0
Status :

Freq Level (dB)

150 23
300 21
450 20
600 20
750 20
900 20
1050 20
1200 20
1350 20
1500 20
1650 20
1800 20
1950 20
2100 20
2250 20
2400 20
2550 21
2700 21
2850 21
3000 21
3150 21
3300 21
3450 22
3600 24
3750 27


Tl Posts:

United Kingdom
Posted - 2/14/2001 12:17:42 PM  Show Profile  Email Poster  Edit Message    LizardKings Homepage
This is exacly what i was gettin (see *28,8k connection on a V90 modem).
It did turn out to be the line as i tried it in a friends comp and it got a v90 straight
It now gets a low rate V90 but only cos the telephone wire from the main box in my house is soldered straight on the modem.
Tl Posts:

Posted - 2/14/2001 4:23:17 PM  Show Profile  Email Poster  Edit Message
OK. I've saw you message after post mine.

But the strange thing is I get V.90 connections with a cheap crappy HSP modem. Same line , same everything except modem of course.

I have suspected all my life that USR were the best modems. Maybe I was wrong.

I've tried with the modem connected to the incoming telco wires. But not actually soldered it. An it didn't work.

The line seems good according AT stuff.

Should I give up hope with 3COM modem - my line combination. Will it ever work if I do something ?

Any ideas ?

and Lizard, please tell me exaclty what you have done with your line-modem connection to made it work.


Tl Posts:

United Kingdom
Posted - 2/14/2001 6:31:28 PM  Show Profile  Email Poster  Edit Message    LizardKings Homepage
I was too getting a V90 on a Genius 56k modem no probs. And i was stressing all the time it was the modems fault. But 1st id get you medem tested on a different line to rule the modem out.
Ive also got a higher quality extension going into my modem.
I dont know were you live but in the UK if we phone up the phone line company we can get the line gain increased (its free here but i dont know about were you live).
And i would'nt recomend soldering your phone line onto your modem unless you are competent with a soldering iron. Also switch off the line if you can as a current still flows threw and can short on the Iron.
Hope you do get it sorted, i was on the verge of puttin it threw the top window of a 10story building.
Also make sure there are no splits in the line were it goes to a different part of your house.
Even thou i ususally only get a 34-40k connection i still get a lower ping in games than that of my Genius modem which usualy connected at 45k. So i guess USR modems arent all that bad.
Tl Posts:

Posted - 2/14/2001 7:15:22 PM  Show Profile  Email Poster  Edit Message  SARGEs Homepage
My old USR gets up to 50666, along with Supra Express (internal and external), Boca Tidalwave, USR internal and even a Lucent. Every USR I've bought the past 2 years wouldn't budge past a v34. Kept none of them.
Tl Posts:

United Kingdom
Posted - 2/15/2001 2:37:23 PM  Show Profile  Email Poster  Edit Message    LizardKings Homepage
I have noticed that USR do seem to be tempomentle about getting a V90 connection. But you really should get it tested on a different line. If it still isnt working then you should consider taking it back and getting a different brand, unless someone else can give you help.
Tl Posts:

Posted - 2/17/2001 10:06:44 AM  Show Profile  Email Poster  Edit Message  v.Richards Homepage
I would suspect that your line is served by digital carrier facilities that the USR firmware is unable to deal with and get a 56k connection.

I would suggest trying to add comma(s) to end of dialed # to see if that makes a difference; if it does not, I would recommend disabling 56k on the modem.
33.6k isn't bad, and probably gives better throughput than the HSP at 38.6k....


Click Here To Close Thread, Administrators & Moderators Only.

Show All Forums |