Modemsite's Forum56 - The Modem Board
Main | profile | register | search | help | Ad-free Login
Forums | USR | USR Sportster 33.6 int. Winmodem unable to open port    Watch  
Author Topic
Tl Posts:

Posted - 7/13/2000 7:08:13 AM  Show Profile  Email Poster  Edit Message
I'm trying to help a friend keep his old 486/50 machine running. Recently, the hard drive had a head crash, and the modem was affected by a lightning storm. I've replaced the hard drive, and re-installed Win95. I've also installed a USR Sportster 33.6 internal Winmodem (just purchased a used one). Win95 successfully identified it, and read the drivers from the floppy. The modem also shows up correctly under (Control Panel, System).
However, whenever I try to run Win95 Diagnostics (Control Panel, Modems, ... 'More Info') I get an error message - 'Unable to open port'. The modem defaulted to COM1, and I have tried changing it to COM2 thru COM4, and I've also tried a different ISA slot, but I still get the 'Unable to open port' message.

Any recommendations on where to go from here? I don't know if the problem is the modem or the system.
I've owned several USR Winmodems without any problems... Thanks, Rick

Rob Law
Tl Posts:

Posted - 7/13/2000 2:05:03 PM  Show Profile  Email Poster  Edit Message
You may have a hardware modem with jumperable com ports and IRQ's. If the modem isn't jumped the same, say com2 as the com port you want to use, it will not open the port. If your modem is not jumped to use the listed IRQ that your com port is using then the "more info" will tell you that the port IRQ's do not match. You may also need to disable the com(1 or 2) in BIOS too and then add new hardware in win for your disabled com to work.

Hope that helps, I love hardware modems but they are not plug and play, it just takes some time to figure them out.

Tl Posts:

Posted - 7/13/2000 3:46:05 PM  Show Profile  Email Poster  Edit Message
Rob, Thanks for the idea. However, there are no jumpers on the modem.

My guess is one of the following:
- modem installed incorrectly.
- motherboard was affected by the lightning that fried the old modem.
- modem is bad.

Tl Posts:

Posted - 7/14/2000 10:27:57 AM  Show Profile  Email Poster  Edit Message  v.Richards Homepage
You indicate the Win95 detected modem & read drivers from the floppy. Where did you get the floppy? Perhaps it does not have correct drivers for Win95 & your modem?

A Winmodem requires matching driver (firmware) and is specific to Operating System; A Winmodem creates its own virtual COM port, and cannot use a COM port already defined by your system BIOS.


Tl Posts:

Posted - 7/15/2000 5:48:02 PM  Show Profile  Email Poster  Edit Message
Problem solved! There was a conflict with the BIOS serial port settings. First, I changed Serial Port A from 3E8 to 3F8, then disabled Serial Port B (2F8).
I'm using a PS/2 mouse. Then I removed the modem and all COM devices from Device Manager, and rebooted.
Then, when I re-installed the modem, it defaulted to COM1, IRQ(9), and IO(110) and still didn't work. I manually changed it to COM2, and IRQ(3), and it works!!
Thanks for your help!

Click Here To Close Thread, Administrators & Moderators Only.

Show All Forums |