Modemsite's Forum56 - The Modem Board
Main | profile | register | search | help | Ad-free Login
Forums | USR | usr5610B usually connects at 1200, rarely 56K    Watch  
Author Topic
Tl Posts:

Posted - 8/9/2002 8:45:51 PM  Show Profile  Email Poster  Edit Message
Short Problem Description: When dialing, about 19/20 times I will get immediate connect at 1200 baud. About 1/20 times I get the 56K connect (actually about 48K). Once connected at 56K, usually after a few hours of good connect time, the modem will suddenly stop working. I am literally dialing 20 times and hanging up to get one good connect.

Background: I returned home one day to find my old USR modem not functioning. There was a + mark in one of the System Device Manager headings. I fooled around with it, couldn't get it to work, bought a new USR 5610B and installed it. It didn't work.

Since then I have done everything I can figure out to try and resolve the problem described above, including reinstalling the modem, reinstalling Windows 98 several times, using the utility to erase the USR entries in the registry, and manually installing the dosbox file from the USR installation disk. I have Nortoned the computer to death and there are no viruses. All system files I could run say everything is ok. But the damn thing has to be dialed a dozen or more times to get me 56K.

Device Manager: Com 1; lists three drivers, all up to date
Device Manager: Modems shows USR V92 Fax PCI; diagnostics tab shows Com 1 no modem, Com 5 USR V92 Fax PCI; driver comm.drv up to date, diagnostics "more info" dumps a bunch of modem info if it is not in use; when the modem is in use it can't find it.

Help and thanks!

Tl Posts:

Posted - 8/10/2002 10:14:11 AM  Show Profile  Email Poster  Edit Message  v.Richards Homepage
Step 1:
After 1200 connect, check the modemlog and post it here. Also get modem diagnostics (ati6i11y11) - see step 2.

Step 2:

Test the modem with Hyperterminal.
(To connect directly to COM5, you will need to d/l the enhanced free Private Edition of Hyperterminal; it's normal for USR PCI h/w modem to install on COM5; even though it's on COM5, some apps may be able to access modem on COM2,3, or 4 - I think; )

You can get post-call diagnostics (ati6i11y11), as well as make test calls to your ISP #.
Your current problem may be in the init string given to the modem, or your h/w PORT speed settings; With Hyperterminal, you can give modem default initialization:
and then dial. What connect speed to you get this way.

The PORT speed, whether in Hyperterminal or DUNs (via connectoid/modem properties) should be set at 115.2k, and must be set to at least 57.6k to get high-speed connections.

Aloha! Richard.

Tl Posts:

Posted - 8/10/2002 5:14:30 PM  Show Profile  Email Poster  Edit Message
Thank you I will get on it and get back and post results as soon as I can get to it and get them.

Tl Posts:

Posted - 8/10/2002 5:23:07 PM  Show Profile  Email Poster  Edit Message
Here is the log file as it is currently being used. Note that this is on a normal connection, but it might provide you a baseline for comparison.
08-09-2002 22:24:47.51 - U.S. Robotics V92 Fax PCI in use.
08-09-2002 22:24:47.53 - Modem type: U.S. Robotics V92 Fax PCI
08-09-2002 22:24:47.53 - Modem inf path: USROBO~1.INF
08-09-2002 22:24:47.53 - Modem inf section: Modem_00D3PnP
08-09-2002 22:24:47.80 - 57600,N,8,1
08-09-2002 22:24:48.02 - 115200,N,8,1
08-09-2002 22:24:48.02 - Initializing modem.
08-09-2002 22:24:48.02 - Send: AT<cr>
08-09-2002 22:24:48.02 - Recv: AT<cr>
08-09-2002 22:24:48.02 - Recv: <cr><lf>OK<cr><lf>
08-09-2002 22:24:48.02 - Interpreted response: Ok
08-09-2002 22:24:48.02 - Send: AT&F1E0Q0V1&C1&D2S0=0<cr>
08-09-2002 22:24:48.02 - Recv: AT&F1E0Q0V1&C1&D2S0=0<cr>
08-09-2002 22:24:48.02 - Recv: <cr><lf>OK<cr><lf>
08-09-2002 22:24:48.02 - Interpreted response: Ok
08-09-2002 22:24:48.02 - Send: ATS6=8<cr>
08-09-2002 22:24:48.02 - Recv: <cr><lf>OK<cr><lf>
08-09-2002 22:24:48.02 - Interpreted response: Ok
08-09-2002 22:24:48.02 - Send: ATS7=60S19=0L1M1&M4&K1&H1&R2&I0B0X4<cr>
08-09-2002 22:24:48.03 - Recv: <cr><lf>OK<cr><lf>
08-09-2002 22:24:48.03 - Interpreted response: Ok
08-09-2002 22:24:48.03 - Dialing.
08-09-2002 22:24:48.03 - Send: ATDT;<cr>
08-09-2002 22:24:48.90 - Recv: <cr><lf>OK<cr><lf>
08-09-2002 22:24:48.90 - Interpreted response: Ok
08-09-2002 22:24:48.90 - Dialing.
08-09-2002 22:24:48.90 - Send: ATDT#######<cr>
08-09-2002 22:25:17.24 - Recv: <cr><lf>CONNECT 46666/ARQ/V90/LAPM/V42BIS<cr><lf>
08-09-2002 22:25:17.24 - Interpreted response: Connect
08-09-2002 22:25:17.24 - Connection established at 46666bps.
08-09-2002 22:25:17.24 - Error-control on.
08-09-2002 22:25:17.24 - Data compression on.
Tl Posts:

Posted - 8/10/2002 5:39:05 PM  Show Profile  Email Poster  Edit Message
OK, after posting the last post I hung up, then tried to re-establish the connection. As usual it connected at 1200, I did nothing at all other than hang up and click refresh which redialed. I got the following modem log. It appears to be identical other than the "connect 1200" and "connection established at 1200" toward the bottom. (I do not think this is a bad ISP modem because this has been going on for about 2 weeks now and I have used this dialin for about 2 years without trouble before. There are lots of modems at the receiving end and it varies which one you get.)

08-10-2002 20:24:07.70 - U.S. Robotics V92 Fax PCI in use.
08-10-2002 20:24:07.71 - Modem type: U.S. Robotics V92 Fax PCI
08-10-2002 20:24:07.71 - Modem inf path: USROBO~1.INF
08-10-2002 20:24:07.71 - Modem inf section: Modem_00D3PnP
08-10-2002 20:24:07.96 - 57600,N,8,1
08-10-2002 20:24:08.18 - 115200,N,8,1
08-10-2002 20:24:08.20 - Initializing modem.
08-10-2002 20:24:08.20 - Send: AT<cr>
08-10-2002 20:24:08.20 - Recv: AT<cr>
08-10-2002 20:24:08.20 - Recv: <cr><lf>OK<cr><lf>
08-10-2002 20:24:08.20 - Interpreted response: Ok
08-10-2002 20:24:08.20 - Send: AT&F1E0Q0V1&C1&D2S0=0<cr>
08-10-2002 20:24:08.20 - Recv: AT&F1E0Q0V1&C1&D2S0=0<cr>
08-10-2002 20:24:08.21 - Recv: <cr><lf>OK<cr><lf>
08-10-2002 20:24:08.21 - Interpreted response: Ok
08-10-2002 20:24:08.21 - Send: ATS6=8<cr>
08-10-2002 20:24:08.21 - Recv: <cr><lf>OK<cr><lf>
08-10-2002 20:24:08.21 - Interpreted response: Ok
08-10-2002 20:24:08.21 - Send: ATS7=60S19=0L1M1&M4&K1&H1&R2&I0B0X4<cr>
08-10-2002 20:24:08.22 - Recv: <cr><lf>OK<cr><lf>
08-10-2002 20:24:08.22 - Interpreted response: Ok
08-10-2002 20:24:08.22 - Dialing.
08-10-2002 20:24:08.22 - Send: ATDT;<cr>
08-10-2002 20:24:09.07 - Recv: <cr><lf>OK<cr><lf>
08-10-2002 20:24:09.07 - Interpreted response: Ok
08-10-2002 20:24:09.07 - Dialing.
08-10-2002 20:24:09.07 - Send: ATDT#######<cr>
08-10-2002 20:24:33.60 - Recv: <cr><lf>CONNECT 1200/ARQ/LAPM/V42BIS<cr><lf>
08-10-2002 20:24:33.60 - Interpreted response: Connect
08-10-2002 20:24:33.60 - Connection established at 1200bps.
08-10-2002 20:24:33.60 - Error-control on.
08-10-2002 20:24:33.60 - Data compression on.

Tl Posts:

Posted - 8/10/2002 6:17:53 PM  Show Profile  Email Poster  Edit Message
More Info

After a dozen connects at 1200 I am back on at 46666.

I tried hyperterminal. For com2,3,4 it says it cannot connect. For com1 it appears to connect (at least it asks me if I want to disconnect when I click out) but there nothing on the page at all, not even an ok in response to a lf/cr. I am about to download and install the upgraded private edition which btw is directly linkable at

Further reports to follow when I get them, I may have to take a break for a little while.

Tl Posts:

Posted - 8/10/2002 6:27:44 PM  Show Profile  Email Poster  Edit Message
I have all the luck. The install program for Private Edition hyperterminal crashed right toward the end of the installation process and I had to three finger out of it (not responding message). I wonder if I should have disconnected first?

It'll be a while; I have some other work to get done, then I will try running the install again.

Tl Posts:

Posted - 8/11/2002 9:22:09 AM  Show Profile  Email Poster  Edit Message
OK, I disconnected from the internet and reran the installation program for Hyperterminal Private Edition. This time it did not crash.

I configured a "new" hyperterminal to communicate directly with port 1, the com port. I got a blank screen. I hit the return key several times, and tried typing AT and various items into the keyboard. Everything was blank on the Hyperterminal Screen (there was not even an OK). I disconnected the Hyperterminal call through Hyperterminal. I then tried making a new call to Com1 and Hyperterminal crashed. I three fingered and in the Close Program Box there were "Acrord32" not responding, and Hyperterminal not responding.

Where do I go from here?

This is driving me nuts, but I am determined to try and resolve it because (get this) I earn most of my living from the internet.

Tl Posts:

Posted - 8/11/2002 9:42:36 AM  Show Profile  Email Poster  Edit Message  v.Richards Homepage
You cannot use COM1 (that's the real COM port included with the computer which is why it shows as available; however, since no modem is attached to it, you cannot 'use' it); you need to use the COM5 in Hyperterminal.

As to the modem log - I do not see anything too unusual - except for the
which tells the modem to wait 8 seconds before dialing; which should be overriden by the X4 command which tells modem to dial as soon as it detects dial tone;

Absent the Hyperterminal tests, I would suggest simply adding
in extra settings to test dial/re-dial & connect speeds;
AT&F1 will override all settings DUNs gave to the modem and connect using modem factory defaults.

One more question - when you connect at 1200, what does the handshake sound like? Do you get "double" handshake?

Aloha! Richard.

Tl Posts:

Posted - 8/11/2002 9:52:55 AM  Show Profile  Email Poster  Edit Message
Try this in extra settings.


Bring the modem and port speed to 115200. Are you using a surg device?Are you using AOL?
Edited by - charles on 8/11/02 10:10:50 AM

Tl Posts:

Posted - 8/11/2002 11:54:10 AM  Show Profile  Email Poster  Edit Message
This is a long message. My comments are started with ........... followed by results on the diagnostics.

After installation of Modem Check got following message
System File Error. The following system files have been replaced with older
versions by a program you recently ran. These files are currently in use and cannot
be automatically repaired. Windows may not run correctly until you exit and restart
Windows so that these files can be automatically repaired:
C:\\windows\system\commctrl.dll; commdlg.dll;msjstick.drv;shell.dll
xxxxxxxxxxxxxxxxx modem check
I was connected at 1200 baud. Entered "autodetect port"
Checking Com5... Could not set comm state, there may be one or more invalid communications parameters..
Checking Com4... Could not set comm state, there may be one or more invalid communications parameters..
Checking Com3... Invalid port number.
Checking Com2... Invalid port number.
Checking Com1... Sorry. Can't Find A Modem!

If You Got A Port Already Open Error, Then Make Sure No Other Windows Programs Are Using Your Modem. EG Auto-Answer For Dial Up Networking/Fax/Answering Machine!

Other Suggestions:
Right Click on MY Computer, Select Properties, Device Manager
If There Is A Yellow Exclaimation Mark Next To Your Modem Double Click On It.
Check That The Modem Is Using The Correct Comport..
Click The Resources Tab. If It Says There is a Conflict You Need To Resolve This By Changing The IRQ.

If That Doesn't Work, Remove Your Modem From the device Manager And Reboot. Your Computer Should Find Your New Hardware And Reinstall The Drivers For It.
Also Make Sure You Have The Latest Drivers Installed.
.......................... next step.................
disconnected from internet (1200 baud) through windows. Went to "work offline" settings.
Ran modem check. Failed to autodetect port. Ran modem check manually settting port to com5.
Got "OK"
Then, AT11 produced the following:
ATI11 U.S. Robotics 56K FAX INT Link Diagnostics...

Modulation V.22
Carrier Freq (Hz)
Symbol Rate
Trellis Code
Nonlinear Encoding
Preemphasis (-dB)
Recv/Xmit Level (-dBm)
Near Echo Loss (dB)
Far Echo Loss (dB)
Carrier Offset (Hz)
Round Trip Delay (msec)
Timing Offset (ppm)
SNR (dB)
Speed Shifts Up/Down/Null 0/0/0
Status :

............................AT 13
TI3 U.S. Robotics 56K FAX INT V5.22.45

............................AT 14
ATI4 U.S. Robotics 56K FAX INT Settings...

B0 E1 F1 L1 M1 Q0 V1 X4 Y0

&A3 &B1 &C1 &D2 &G0 &H1 &I0 &K1
&M4 &N0 &P1 &R2 &S0 &T5 &U0 &Y1

S00=000 S01=000 S02=043 S03=013 S04=010 S05=008 S06=004
S07=060 S08=002 S09=006 S10=014 S11=070 S12=050 S13=000
S15=000 S16=000 S18=000 S19=000 S21=010 S22=017 S23=019
S25=005 S27=000 S28=008 S29=020 S30=000 S31=128 S32=002
S33=000 S34=000 S35=000 S36=014 S38=000 S39=000 S40=001
S41=000 S42=000

LAST DIALED #: T8937100

..............AT 16
ATI6 U.S. Robotics 56K FAX INT Link Diagnostics...

Chars sent 16690 Chars Received 29879
Chars lost 0
Octets sent 10743 Octets Received 28121
Blocks sent 417 Blocks Received 270
Blocks resent 0

Retrains Requested 0 Retrains Granted 0
Line Reversals 0 Blers 0
Link Timeouts 0 Link Naks 0

Data Compression V42BIS 0/0
Equalization Long
Fallback Enabled
Protocol LAPM/SREJ
Speed 1200
Last Call 00:04:02

Disconnect Reason is DTR dropped

................AT 17
ATI7 Configuration Profile...

Product type US/Canada Internal
Product ID: 00561002
Options V32bis,V.80,V.34+,V.90,V.92
Fax Options Class 1/Class 2.0
Line Options Caller ID, Distinctive Ring
Clock Freq 92.0Mhz
EPROM 256k
RAM 32k

FLASH date 9/11/2001
FLASH rev 5.22.45

DSP date 9/11/2001
DSP rev 5.22.45

Freq Level (dB)

......................AT#UD (had to press "send command" button
DIAG <2A4D3263 00=10>

DIAG <2A4D3263 01=7>

DIAG <2A4D3263 02=00>

DIAG <2A4D3263 03=00>

DIAG <2A4D3263 10=00 11=00>

DIAG <2A4D3263 12=00 13=70>

DIAG <2A4D3263 14=00 15=00>

DIAG <2A4D3263 16=00 17=00>

DIAG <2A4D3263 20=02 21=02>

DIAG <2A4D3263 22=0000 23=0000>

DIAG <2A4D3263 24=0000 25=0000>

DIAG <2A4D3263 26=04B0 27=04B0>

DIAG <2A4D3263 30=00 31=00 32=00 33=00>

DIAG <2A4D3263 34=04B0 35=04B0>

DIAG <2A4D3263 40=1 41=080>

DIAG <2A4D3263 42=00 43=00>

DIAG <2A4D3263 44=1 45=800>

DIAG <2A4D3263 50=2 51=2>

DIAG <2A4D3263 52=00004132 53=000074B7>

DIAG <2A4D3263 54=0000 55=0000>

DIAG <2A4D3263 56=000001A1 57=0000010E>

DIAG <2A4D3263 58=00000000 59=00000000>

DIAG <2A4D3263 60=20>


............................... end testing .........................................

Tl Posts:

Posted - 8/11/2002 12:02:55 PM  Show Profile  Email Poster  Edit Message
To Charles: Thanks, I want to make it through the diagnostics and post them before I make any changes, just in case.

I will try the initialization you gave me when I am done.

I am not on AOL and have never been anywhere near the place

I am not as far as I know using a surg device. Since this problem started during a lightning storm, I wonder if you mean surge device and why you ask? (I'm not trying to be a smart butt here, maybe it was a typo?)

The port is already set to 115xxx. So is the modem is set to 57xxx. This is per the system device manager in Control Panel. Playing around with these settings in the past had no apparent effect.

What gets me about this is that about every 10-15 tries I get a perfect connection. Just rings, and immediately connects at ~ 56K. Something is obviously randomly hitting the right condition. But it is not something that appears to be effected by rebooting; makes me wonder if I have a CMOS problem but I am in over my head here obviously.

Tl Posts:

Posted - 8/11/2002 12:48:06 PM  Show Profile  Email Poster  Edit Message  v.Richards Homepage
It could be the modem itself - intermittent - borderline/failing component.

You cannot do diagnostics / modemcheck, hyperterminal, etc. if the modem is in use - only when modem is idle & not connected - that's normal.

Aloha! Richard.

Tl Posts:

Posted - 8/14/2002 12:54:35 PM  Show Profile  Email Poster  Edit Message
I agree. Looks like a failing modem to me. Not suprising to me that a USR modem would break. I bought 6 and returned them all because they wouldn't go off-hook after a week! Talk about bad luck! Anyway, I'm currently happy with cable...
Tl Posts:

Posted - 8/19/2002 2:40:54 PM  Show Profile  Email Poster  Edit Message
Make sure your modem card is seated in the motherboard properly. I had to modify my modem frame to get it to seat properly. This is due to my motherboard, I believe. You could also try switching PCI slots to get a better fit.
Tl Posts:

Posted - 8/20/2002 6:54:28 PM  Show Profile  Email Poster  Edit Message
OK, more info. I pulled the USR modem and deleted it on modems through control panel, ran the USR registry cleaner, and pulled it out of the box. (btw, it was seated well and firmly through all this)

I bought a Broadexent DSI V.92 at Walmart for under $ 30. It installed right away, and was immediately recognized and connected each and every time at 56K.

However additional problems developed. No matter what I did (including reinstalling the USR, and changing the ports at a basic level, and changing the ports through the advanced resources settings), I could only receive a total of 365 (sic) bytes.

I got on the phone to my ISP -- 3 modems later could this be a problem at that end? No, but he (got to be one of the better techs at Earthlink) actually started sending me packets directly to my modem, and figured out that I had a corrupted windows driver in the TCP/IP Dial Up Adapter!

Problem is, I deleted that and it requires the original disk to reinstall, so I am SOL right now. I have the upgrade but not the Windows Second Edition, which I need a few files from -- and that costs $ 200.

So I'm typing this on my laptop. I figure I will eventually find a local friend with the install disks. Meanwhile I'm gonna hobble by on the laptop and look for a whole new box -- mines a couple years old anyway, and I hate to dump more money into it.

Thanks to those on this board for your help. If I reinstall and it works I will let you know by posting here.

And no thanks to USR and their screwed up nonsupport policies.

Topic is 2 Pages Long:    1 2

Click Here To Close Thread, Administrators & Moderators Only.

Show All Forums |