Modemsite's Forum56 - The Modem Board
Main | profile | register | search | help | Ad-free Login
Forums | USR (Public) | USR5686 stops responding or disconnects    Watch  
Author Topic
Tl Posts:

Posted - 7/31/2004 7:04:44 AM  Show Profile  Email Poster  Edit Message
Didn't want to jack dtc's thread, but my problem is extremely similar.

Lightning did not strike. In addition, I had everything running through my UPS.
Modem is external.

Everything worked just fine for over a year. About the middle of June, there were sporadic instances when it seemed the ISP's modem would not respond for about 5 minutes then would start responding again.
Started getting more frequent and getting disconnects. Modem log reports that the remote modem hangs up.

Several calls to the ISP and to the telco. ISP says there is nothing wrong. Telco sent a guy out three times to check the line. The last time I was here. He hooked in to the demarc and said that noise was <20db. He also told me that the CO had move a few months prior and the line is all fiber optic to about a mile from my house.
Oh yeah, this is a dedicated line. Nothing else attached except the UPS.

Here's where it gets bizarre: the no-response/disconnect incidents usually happen about 4 minutes after the hour, 22 after, and 16 til the hour. This is according to "wall time" regardless what the system clock is set to.
Sometimes, however, the incidents occur every 5 or 10 minutes (that is, get a response then wait another five or ten before I can get another or get disconnected).
This is rain or shine, hot & humid, hot & dry, cood & humid, cool & dry, on-peak and off-peak.

My laptop does not have the problem, using either the built-in modem or a Xircom modem card.

The steps I have taken so far:
Re-checked for viruses, spyware, hidden devices, etc. None there.
Swapped out the modem with another 5686. Swapped out the serial cable. Moved the modem and lines so they are fairly isolated. No joy.
Tried varieties of init strings to disable v.92, disble v.90, disable variable port speed, step down connect speed. No joy.
"Wash & wax" and reloaded the OS (Win2K) and IE only. Same story.

I just ordered the Modemsite DSP modem. Who knows? Maybe the external modem is too sensitive to current line conditions. I had a PCChips mobo at one time with a built-in modem that, in town could connect consistently at 50K, but out here in the boonies could only manage 9600, if it could connect at all.

Modem log reports noise levels like this):
Received signal power level (in -dBm): 231
Transmit signal power level (in -dBm): 61
Estimated noise level (in -dBm): 12
Normalized Mean Squared error: 0
Near echo loss: 123 dB
Far echo loss: 0 dB
Far echo delay: 0 ms

The numbers are almost always close to these. Except the estimated noise level. It varies between the teens, as seen here, to over 200.

Anybody got clues?

Tl Posts:

Posted - 7/31/2004 9:17:25 AM  Show Profile  Email Poster  Edit Message
This could be a problem with the serial port itself,most often buffer over run. What OS is on the laptop? Do you have any program running in the background that is connected some way to the connection. Any thing that is checking with aouto update. End task anything that is not needed,check connection.
Check settings

Some other things to check

Do you have a NIC card and not using it? Check connection/
Has this modem been flash and what is the model USR5686 D,E,or -02 -03?
Have you disabled call waiting.Is there anything sharing the IRQ with this modem?
Check the inf that is installed for this modem.
Many U.S. Robotics products are listed in Windows 2000 and Windows XP. The products listed below with the will install on Microsoft Windows 2000 or Windows XP. Modems will install with basic modem functionality.

Tl Posts:

Posted - 7/31/2004 1:01:29 PM  Show Profile  Email Poster  Edit Message
Thanks, Charles

The OS on the laptop is Win2K, SP4, same as on this machine.
Nothing else is trying to talk to the outside world. The only thing that sends traffic out is IE (and ping when I use it).
The FIFO buffers on the laptop are set "wide open". FIFO buffer settings on this machine make no difference as far as the no-response/disconnect.
Before I rebuilt, I had auto update disabled. I haven't set it up since the rebuild.
I checked the settings outlined at stargate. I'm in synch except I don't have "logon to MS Network" checked. That has always been a waste of time.
I do have a NIC installed. But it has been there four years (this is the third machine) without causing problems. Remember, everything was running fine, without changes, until the middle of June.

I had flashed the "old" external modem. No change. The "new" one is still running the older version firmware.
The phone line is "bare bones". No call waiting to disable. The IRQ used by the COM port is not used by anything else. I have tried uninstalling, making sure that everything is truly gone (including the "oem" inf file, and installing the modem on the other COM port. I get the same results on COM1 and COM2.
Each time I install the modem, I check the "oem" inf file that is created and is used by the modem. It is a copy of the 5686 inf file that I tell the install to use (verified by the modem log).
I hate to tell USR, but Win2K, if left to its own devices, installs the modem as a "standard unimodem". And the driver for the 5686 does not show up in Windows' list of drivers.
It's a USR5686E (03).

I'm suspecting noise even more now. During a couple-hour session, I usually get 4 or 5 Error Link Timeouts and the same for NAKs. My receive/transmit levels are notably high, as is the Near Echo Loss (see original post).

Thanks again. I'll keep digging...

Tl Posts:

Posted - 7/31/2004 3:51:52 PM  Show Profile  Email Poster  Edit Message
Have you tested this line with hyperterminal using the ati6
ati11 aty11

Have you tried the connection with everything disconnected from the phone jacks. Have you tried other phone jacks? Do you hear any cross talk on the phone? Have you tried this string.note the spaces.
+PIG=1 +PMH=1 +PQC=3

Tl Posts:

Posted - 8/1/2004 9:38:42 AM  Show Profile  Email Poster  Edit Message  v.Richards Homepage
Take the USR modem & the laptop to other locations (ideally with 1 being at a location served by a different telco central office) and see what happens.
If location you are at has add'l phone lines, try the modem on other phone line. You could also try the USR modem at present location but connected to laptop.
Should help to pinpoint whether problem is related to PC; phone line, etc.

It could be that the telco's change in facilities has 'caused' the problem --
I've seen a number of cases where fiber between telco CO and customer significantly impairs modems.

Aloha! Richard.

Tl Posts:

Posted - 8/1/2004 5:34:05 PM  Show Profile  Email Poster  Edit Message
There is only one jack for that line. Nothing else is connected. I had the phone line running through my UPS for several months before the problem started. Since then, the line goes directly to the modem and I unplug it when not connected. I'll give the string a try...

I haven't tried connecting the modem to the laptop. Yet. I'm going to connect a few times with the laptop's internal, capturing a log, and see what it reports re: line noise. Then I'm going to connect the external to the laptop and see if it behaves the same with it.
Next step will bo to go out on the deck and connect straight from the demarc to the external (to the laptop) and to the laptop's internal to see if there is any difference. Could be the wiring from the demarc to the jack is going flaky.

Thanks, guys.

Tl Posts:

Posted - 8/17/2004 6:31:53 PM  Show Profile  Email Poster  Edit Message
So far so good. With the Modemsite modem, that is.

The internal modem in the laptop was reporting much lower noise levels than the external USR. So that sort of confirmed my suspicions that the USR was too sensitive to noise on the "upgraded" phone line.

Got the Modemsite modem, hooked 'er up, and everything is everything so far. To prove to myself that the connection was solid, I used VPN to connect to my machine at a client site, checked email there, and used it to administer one of the web servers. All in all, I was connected for three hours, sending/receiving some heavy traffic over the phone line.
No problems. No "stalls". And, most importantly, no disconnects.

Thanks, Richard, for the heads up on the Modemsite modem.
And thanks to charles for the tips.

Click Here To Close Thread, Administrators & Moderators Only.

Show All Forums |